Correction: The issue began at approximately 18:40 ET, not 18:40 UTC as previously stated.
We have resolved the issue that was causing delays for our warehouse customers in the EU1 region, and all systems are now fully operational.
Our team will continue to ensure all data is processed correctly. We appreciate your patience and apologize for any inconvenience this may have caused.
Posted Feb 25, 2026 - 17:06 EST
Update
We have implemented a fix for the issue that began around 18:40 UTC, which was causing delays for our warehouse customers in the EU1 region. The system is now catching up.
Our team is taking steps to ensure all data is processed accurately, and we will post another update once all processing is back to normal.
Posted Feb 25, 2026 - 14:36 EST
Monitoring
We are currently monitoring an issue that is causing delays for warehouse customers located in our EU1 region. Customers may experience slower than normal processing times.
We have identified the root cause and will continue to monitor the situation. We will provide another update as soon as we have more information.