The trial signup form is currently experiencing issues
Incident Report for Fullstory
Resolved
This incident has been resolved.
Posted Apr 15, 2020 - 13:38 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2020 - 09:30 EDT
Investigating
We've detected that some customers are unable to sign up for trial accounts.
Posted Apr 15, 2020 - 09:16 EDT
This incident affected: FullStory Web Application.