A fix was released November 13 at 6:10pm (EST) for the GetSegments and ListSegments API issue. All issues are now resolved.
During the outage window, any requests to either of these APIs (to retrieve either a list of all segments or information on a specific segment) could have returned incomplete data or otherwise would have returned in an error. For any Fullstory customers that made requests to either endpoint during the outage timeframe, we suggest making the same requests again to ensure you have complete and accurate data about the segment(s) in your Fullstory account.
If you have any further questions regarding this issue, please contact us at support@fullstory.com.
Posted Nov 13, 2025 - 18:45 EST
Update
We have identified a solution for the GetSegments and ListSegments API issue and are implementing a fix. We will provide an update once the fix is released. If you have any questions regarding this issue prior to our next update, please reach out to support@fullstory.com for assistance.
Posted Nov 13, 2025 - 14:23 EST
Update
We are continuting to work towards a resolution to restore full functionality and complete data for the GetSegments and ListSegments APIs. We'll provide another update by 3:00pm (EST) tomorrow after further work and testing has been done. If you have any questions regarding this issue prior to our next update, please reach out to support@fullstory.com for assistance.
Posted Nov 12, 2025 - 18:43 EST
Identified
From October 27, 2025 at 11:37am (EDT) to November 7, 2025 at 11:12am (EST), the datastores which serve our GetSegments and ListSegments APIs were unintentionally no longer updated. Requests made to these endpoints during this timeframe may have not returned complete data. Starting November 7 at 11:12am (EST), requests to these APIs began returning an error. We are currently identifying the appropriate resolution and will continue to provide updates on progress.
If you believe your account was impacted or have any questions, please reach out to support@fullstory.com.